Jump to content
ECUForum Community

настройка Open Port 2.0 и стороние программамы


Recommended Posts

Думаю тема актуальна.

Поделюсь опытом.

Я работа на всех видах оперативных систем,многие пишут что лучше видовс ХР быть не может,не буду спорить,но подчеркну момент что уже как 2 месяца майрософт не поддерживает данную оперетивную систему. у меня есть два компьютера один стационар виндовс 7,второй это ноутбук виндовс 8.

И так сначла мною было куплена програма для записи в ЭБУ ChipLoader. Работал ей нормально через К-лайн адаптер,все было хорошо, но смутило следующие. при отсутствие в порте usb устройсв программа всегда видила какой то порт,не обратил внимание,работает и ладно. На днях пришел OpenPort 2.0(по нему ,его работе,его обновление и его программе от Tactrix Ecuflash, напишу ниже отдельно.) так вот устанавливаем драйвера,можно скачать с сайта http://www.tactrix.com/downloads/openport2_setup_1004250.exe,НО!!!! сначла опять вернемся к OpenPort 2.0.Сейчас выпушенна новая программа Ecuflash,в ней уже содержаться драйвера для адаптера,но при ее установке и подключению адаптера программа попросит обновить OpenPort, НЕ делайте этого если вам OpenPort понадобиться в других стороних программах. Актуальная на сегодняшний день версия программы Ecuflash для работы дальнейшей работы с другими програмами без проблем и траблов ecuflash_1443721.

 Снова возврашаемся к работе с ChipLoder, и так не знав все что вше написанно мне повезло адаптер не обновился)) поэтому снес новую версию программы и установил ту которая протестирована. И вот тут тот порт который ChipLoder постоянно видил мне очень сильно сложнил жизнь, Опен потр был виден программой,но программа не могла выбрать его так как постоянно сидел какой якобы другой подключенный порт.фото ниже

2P1XaetJL4c.jpg

 

часа 4 танцов с бубнов не дали не чего конкретного,обратился за поддержкой на ЧИп софт.

Мне ответили

 

Здравствуйте. Приобрел опен порт для работы с Чип лодером,открываю
 программу, в настройках в вкладке J2534 Опен порт  виден,но на
 вкладке основное не виден опен порт.

 

Все у Вас нормально. В основном ничего и не должно быть.

 Вот тут я стал вспоминать что и когда устанавливал,хотел уже снести систему и постваить новую,но вот обратил внимание в диспечере устройств на составное  USB устройсвто,работает нормально и подключенно,не долго думаю удалил , очень удивился тем что Опен порт стал работать одекватно.

Файлы для работы.

Проверенная программа для работы с Ecuflash,а так ж с другими сторонимии программами ecuflash_1443721 http://file.sampo.ru/d64tz5/

Link to comment
Share on other sites

НЕ делайте этого если вам OpenPort понадобиться в других стороних программах.

 

Не надо так категорично, у меня стоит последняя версия и ПО адаптера обновлено, работает все что мне попадалось. Есть конечно возможность взять не обновленный адаптер, если возникнут проблемы, но тем не менее. К тому же приборы в новых партиях скорее всего пойдут с последней актуальной версией ПО и тут задача для разработчика, в первую очередь, решить вопрос совместимости своего ПО. Для этого у них есть аккаунты в тактрикс, доступ к свежим версиям API и баг-трекеру.

 

Снова возврашаемся к работе с ChipLoder, и так не знав все что вше написанно мне повезло адаптер не обновился)) поэтому снес новую версию программы и установил ту которая протестирована. И вот тут тот порт который ChipLoder постоянно видил мне очень сильно сложнил жизнь, Опен потр был виден программой,но программа не могла выбрать его так как постоянно сидел какой якобы другой подключенный порт.фото ниже

 

 

Сам сталкивался с такой же проблемой. Вы её не очень точно написали. В данном случае в системе присутствует устройство эмулирующее COM-порт, Chiploader определяет его как k-line адаптер, хотя фактически оно таковым не является, и не дает сохранить настройки. Соответственно выбрать J2534 адаптер. 

 

В данном случае по скрину видно что это адаптер Bluetooth, поэтому решения  тут два: 

 

- на время сохранения настроек подключить реальный адаптер k-line и выбрать его в этом меню. 

- на время сохранения настроек отключить в диспетчере устройств - bluetooth адаптер.

 

Ну или если вам не нужен bluetooth - можно совсем удалить устройство как и поступили вы. 

Link to comment
Share on other sites

bluetooth был отключен.

это был вертуальный какой то USB порт.

Edited by Vasiliy Armeev
удалено цитирование предыдущего сообщения
Link to comment
Share on other sites

  • 3 months later...

Я кстати тоже сторонник правила - если работает, то не трогай. Проблема Опенпорта2 в том, что прошивку назад вернуть нельзя. На последнем обновлении Опенпорта2 я заметил 2 проблемы: 

1. Перестал работать CAN на скорости 1 Mb/s (похоже проц чем-то дополнительным нагрузили и он не успевает обрабатывать поток данных)

2. Некорректная интерпретация данных в протоколе ISO9141 (KLine)

Link to comment
Share on other sites

  • 3 months later...

Привет всем. У меня  к сожалению проблемы  с  Опенпортом2 . Где  то месяца два  назад по какой то дурацкой надобности подддался на предложение им обновил микропрограмму адаптора до версии   1.15.4340. вначале ничего особенного не заметил , а потом обнаружил  что модуль Чиплоадера МЕ17.9.11 tyuning   а так же  модуль MultiFlesherа   МЕ17.9.11ОBD2  не  грузят  в режиме  OBD2    хоть на столе,хоть на машине  (ошибки опенпорта). Мучаюсь уже недели две. По наводке Михаила(Ромик)  установил DLL  V:1.00.3721 .-- не  помогло.Подскажите как вернуть старую версию микропрограммы. Или выхода нет.? Ведь все же работало годами.Зачем америкосы напакостили? А  новый адапатор Дениса это все решит?

Link to comment
Share on other sites

  • 1 month later...

Думаю тема актуальна.

Поделюсь опытом.

 

Большое спасибо вам!!!!!!!!! День промучился не мог настроить OpenPort с ChipLoder. хотя с другими прогами работает ! А раньше все работало и вдруг перестало!Хотел уже другую винду установить и тут попалась ваша статья!Удалил драйвера блютуз и все работает!!!!!! :)
Link to comment
Share on other sites

  • 1 month later...

извините что поднимаю эту тему, так у меня проблема и висит. если op2 открываю совместно chiplod.  все норма, а если открываю mmc flacher совместно op2. то выскакивает ошибка. если я меняю в систем32 файл, то все работает, но потом не работает chiplodырем. приходится лезть в систем 32. и менять назад файл. файл dll. винда xp.

Link to comment
Share on other sites

  • 10 months later...
  • 1 year later...
  • 1 year later...

Пардон за ап старой темы, но возможно кто-то сталкивался. Tactrix при работе через odis (как 3.0.3, так и 4.2.3 и любой инженерки) не видит авто 2000-х годов, это косяк программной части, или в принципе они не совместимы в этой связке для kwp2000?

Link to comment
Share on other sites

  • 8 months later...

Здравствуйте! Подскажите, есть ли какие проблемы с последними драйверами с официального сайта на ОР при работе с ММС, РСМ, Мультифлешером и Комбиком?

Edited by TDI71
Ошибка
Link to comment
Share on other sites

17.05.2018 в 04:12, j4fme сказал:

Пардон за ап старой темы, но возможно кто-то сталкивался. Tactrix при работе через odis (как 3.0.3, так и 4.2.3 и любой инженерки) не видит авто 2000-х годов, это косяк программной части, или в принципе они не совместимы в этой связке для kwp2000?

Насколько я понимаю, не совместимы. 

28.01.2019 в 10:55, TDI71 сказал:

Здравствуйте! Подскажите, есть ли какие проблемы с последними драйверами с официального сайта на ОР при работе с ММС, РСМ, Мультифлешером и Комбиком?

Лично у меня никаких проблем с PCM/MMC и Multiflasher не было, однако позиция авторов загрузчиков по этому поводу отличается, и если хотите избежать их с максимальной вероятностью, изучите рекомендации от авторов ПО. Но я сам что-то шью не так уж и часто. Основное время, я уделяю анализу логов и калибровке на заказ. 

Openport удобен, а в некоторых случаях почти незаменим (есть софт, который до сих пор только под него и его драйверы и оптимизирован) и достаточно дешев, но время не стоит на месте и сейчас куча адаптеров, за вполне вменяемые деньги, которые, по крайней мере по CAN с высокими скоростями, работают гораздо стабильнее и лучше. Вот Dialink, неплох, например; Сканматик 2 PRO очень хорошо получился... это в бюджетном сегменте. Так что советую приобрести себе еще что-то и не париться с откатом версий. 

Link to comment
Share on other sites

  • 1 year later...

Мужики подскажите пожалуйста может кто сталкивался ....

при подключении ОПЕНПОРТ 2.0 к ОБД2 авто выкидывает на табло сообщение DIAG. Как будто замкнуло что-то.

Такое впечатление как будто авто диагностируют скрепкой .... аналогичный эффект описан в интернете при замыкании 4 и 13 контакты TC и CG.

Может кто сталкивался ??? можно починить или все - на выброс???? 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...